This project has moved. For the latest updates, please go here.

Sorry, this tool is practically unusable

Aug 2, 2008 at 7:26 AM
I am sorry to say that though it might take the author of this tool a lot of time writing the code, but currently I see that this tool is practically unusable.

Selecting a node and all child nodes makes me wait for ever, and UI responsiveness is EXTREMELY SLOW. I wonder if it is done in multi-threaded techniques.

Can't we just pre-select nodes and have another button that says 'Start Downloading my selected content'?
Coordinator
Aug 4, 2008 at 6:02 PM
Thanks for the input. The current code can't handle what you want, but I'm working on a redesign to make the tool more useful. The main problem is that content selection needs to be separated from content download, as you mentioned. The code was not designed to download very quickly because of concerns over the ability of the content service or proxies to handle all the requests. Several times I received exceptions that the proxy received too many requests per second. I'm reworking it so it responds to the exception and slows the requests.

Also, to name some other features:
  • The download dialog needs to be removed and be reimplemented in the status bar or status pane (so the window can be minimized, etc).
  • Content should be cached on disk so it can be reused.
  • Duplicate pictures should be detected and replaced with a single instance.
  • Multithreaded downloading (I wrote a command-line tool that downloads six times faster than single-threaded).

Dec 3, 2009 at 5:36 PM

Hi,

First of all, let me congratulate you and your team for making PackageThis. Its a great peice of software and an amazing innovation.

However, I tried to make a .CHM file for ISA2006 and its children, I am unable to do that. I see a prompt coming for a fraction of a second and disappear.

Moreover, most of the Menu Links in TOOL, EDIT etc are greyed out.

I can create small (1-2 page) files but cannot create a chm for ISA 2006.

I cannot even load a selction XML.

 

Any suggestions why am I facing is this bug?

 

Thanks,

Amit Saxena